Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9171

Debugger: debugger hangs against 8.1.0 SDK on first breakpoint in ti.main.js

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.2
    • Fix Version/s: Release 5.1.3
    • Component/s: Debugging
    • Labels:
      None

      Description

      Using the latest SDK master build (8.1.0.v20190510101759) the build error is no more and the project builds and installs successfully on Android emulator during debug.
      However noticed that when we use this SDK with studio 5.1.2.201903111843 (the 5.1.2 GA version) to debug a project the studio hangs as soon as the breakpoint is hit (an anonymous breakpoint). Does not hang when the same project is debugged with SDK 8.0.0.GA or 8.0.1 builds.
      But when I used this latest 8.1.0 SDK build with the studio build 5.1.2.201905072059 which is the build for the studio PR to fix https://jira.appcelerator.org/browse/TISTUD-9166 there is no hang during debug.

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              ssekhri Satyam Sekhri
              Reviewer:
              Satyam Sekhri
              Tester:
              Satyam Sekhri
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: