Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9166

iOS Debug: The iOS debug breaks on few anonymous files before app launches

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.2
    • Fix Version/s: Release 5.1.3
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Mac OS 10.13.6
      Appc Studio: 5.1.2.201812191831
      Ti SDK: 8.0.0.v20190130052111
      Appc CLI: 7.0.10-6
      Node.js: 8.12.0

      Description

      Debug of alloy or classic app on iOS device or iOS simulator breaks few times on anonymous files before the app launch or the user added breakpoint.

      This happens with 8.0.0.X SDK builds and the issue is not seen when the app is built with 7.5.0.GA

      Steps to Reproduce:
      1. Create an alloy or classic app
      2. Set a breakpoint in a js file in the created app project
      3. Debug on iOS simulator or device

      Actual Result:
      The debug process breaks at few anonymous files before the app launch and before it hits the user added breakpoint.
      Check the screenshots as well from studio showing the debug stack

      Expected Result:
      The debug process should break at the user added breakpoint

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              ssekhri Satyam Sekhri
              Reviewer:
              Satyam Sekhri
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Synchronized with TIMOB
                  Synced with:
                  TIMOB-21005
                  Sync status:
                  PENDING
                  Last received:
                  Last sent: