Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9161

iOS Debug: The debugger does not connect when trying to debug second time

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.2
    • Fix Version/s: Release 5.1.3
    • Component/s: Debugging
    • Labels:
      None
    • Environment:

      Mac OS 10.14.3
      Studio: 5.1.2.201903051616
      Ti SDK: 8.0.0.v20190219113758
      Appc CLI: 7.0.10-master.17
      Node: 8.12.0
      JDK: 9.0.4
      XCode: 10.1

      Description

      When trying to debug on iOS sim/device for the second time without killing the previous instance of app on the device the debugger does not connect.

      This happens only for iOS. The issue does not occur on Studio 5.1.1

      Steps to Reproduce:
      1. Create a titanium project. Add a breakpoint in a js file
      2. Debug on iOS simulator or device. The debugger connects successfully and breakpoint is hit.
      3. Terminate the debug process by clicking the red square/stop button in debug window or select Terminate option from context menu in debug window.
      4. With the app from previous instance still showing up on the simulator, i.e. we did not kill or delete the app, try to debug on the same simulator/device again

      Actual Result:
      The debugger does not connect the second time

      Expected Result:
      The debugger should again. Even if the previous debug instance was not terminated manually it should get terminated when running debug again.

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              ssekhri Satyam Sekhri
              Reviewer:
              Satyam Sekhri
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: