Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9159

iOS Debug: Not able to debug on iOS Simulator version 11.3

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.0
    • Fix Version/s: Release 5.1.2
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Mac OS 10.13.4
      Studio: 5.1.0.201804161553
      SDK: 7.1.1.v20180419111054, 7.1.0.GA, 7.0.2.GA
      Xcode: 9.3
      Appc CLI: 7.0.2, 7.0.3-39
      Node: 8.9.1
      JDK: 1.8.0_162

    • Story Points:
      8
    • Sprint:
      2019 Sprint 4

      Description

      Debug not successful on iOS simulator v11.3. The breakpoints are not hit.

      Debug of same application worked for iOS simulator v11.0, v10.3

      The results are same irrespective of different SDK and CLI versions.

      Steps to Reproduce:
      1. Create a default alloy project
      2. In index.js, add some breakpoints
      3. Debug on any iOS simulator of version 11.3

      Actual Result:
      Breakpoints not hit. The project builds and launches successfully on the simulator.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cwilliams Christopher Williams
                Reporter:
                ssekhri Satyam Sekhri
                Reviewer:
                Kondal Kolipaka (Inactive)
              • Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Synchronized with TIMOB
                    Synced with:
                    TIMOB-6394
                    Sync status:
                    ERROR
                    Last received:
                    Last sent: