Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9137

Studio prompts for hyperloop plugin update with SDK > 7.0 if hyperloop folder inside modules directory is deleted.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.2
    • Fix Version/s: Release 6.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OS 10.13.4
      Appc Studio: 5.1.2.201810080801
      Ti SDK: 7.4.0.GA
      Appc CLI: 7.0.6
      Node.js: 8.9.1
      JDK: 9.0.4

    • Story Points:
      3
    • Sprint:
      2018 Sprint 22 Studio

      Description

      Check for updates in Studio prompts for update of Hyperloop plugin even though there is no Ti SDK < 7.0. This happens only after deleting the Hyperloop folder that exists under modules.

      Steps to Reproduce:
      1. Delete the Hyperloop folder from ~/Library/Application Support/Titanium/modules/android/ or ~/Library/Application Support/Titanium/modules/ios/
      2. Ensure the ~/Library/Application Support/Titanium/mobilesdk/osx/ has SDK only >= 7.0
      3. In Studio, check for updates

      Actual Result:
      The updates show an update for Hyperloop plugin to 1.2.8

      Expected Result:
      There should be no update prompt for Hyperloop when there are no SDK < 7.0

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                ssekhri Satyam Sekhri
                Reviewer:
                Prashanth Pedduri (Inactive)
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: