Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-9115

Studio 6.0 GA: Update Node.js version distributed by Studio

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 6.0.0
    • Component/s: Node, Update
    • Labels:
      None
    • Story Points:
      13
    • Sprint:
      2019 Sprint 23

      Description

      I believe the version Studio distributes is v8.9.1 or something. We have a npm dependencies that uses a new ES2018 feature (dotAll & lookbehind regex support) and so the minimum required version will be Node.js v8.10.0.

      The latest LTS release is v8.11.4 and it's the version that we test, so please update Studio's installer to install Node.js v8.11.4.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cwilliams Christopher Williams
                Reporter:
                cbarber Chris Barber
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: