Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8917

Unable to update Hyperloop & TouchTest Module

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Hyperloop
    • Labels:
    • Environment:

      Studio 4.10.0.201709271713

    • Story Points:
      5
    • Sprint:
      2017 Sprint 24 Studio

      Description

      Problem

      Customer is having issues upgrading the Hyperloop & TouchTest modules from Appcelerator Studio. We get a prompt for upgrade (notifying updates are available to install), when we click install, we get an error saying "unable to find valid certification path to requested target". Please see the details below.

      Studio version: 4.10.0.201709271713

      Errors from log file: (see attached screenshots as well)

      !ENTRY com.aptana.core.epl 2 0 2017-11-17 08:17:13.551 
      !MESSAGE Connection to https://appcelerator-modules.s3.amazonaws.com/hyperloop-2.2.2.zip failed on sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Retry attempt 0 started 
      !STACK 0 
      javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target 
      at sun.security.ssl.Alerts.getSSLException(Alerts.java:192) 
      at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949) 
      at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302) 
      at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296) 
      at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1514) 
      at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216) 
       
       
      !ENTRY com.aptana.core.epl 2 0 2017-11-17 08:17:14.767 
      !MESSAGE Connection to https://appcelerator-modules.s3.amazonaws.com/MakeAppTouchTestable.zip failed on sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Retry attempt 0 started 
      !STACK 0 
      javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target 
      at sun.security.ssl.Alerts.getSSLException(Alerts.java:192) 
      at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949) 
      at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302) 
      at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296) 
      at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1514) 
      at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216) 
      at sun.security.ssl.Handshaker.processLoop(Handshaker.java:1026) 
      

      Note

      1. Customer might be under a secured network. But upgrade was working well before.
      2. Studio and SDK upgrade seems working well., only those two module having problem.

      Any idea?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka
                Reporter:
                sliang Shuo Liang
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • It looks like Backbone Issue Sync is not enabled for your project.