Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8819

Error in Create Android AVD window when JDK 1.8 not installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.9.0
    • Fix Version/s: Release 4.10.0
    • Component/s: Android
    • Labels:
      None
    • Environment:

      Mac OS 10.12.4
      Ti SDK: 6.1.2.v20170710160853
      Appc Studio: 4.9.1.201707120606, 4.9.0.201705302345
      Appc NPM: 4.2.9
      App CLI: 6.2.2
      Node v6.10.3

    • Story Points:
      5
    • Sprint:
      2017 Sprint 17 Studio

      Description

      When JDK 1.8 is not installed on the system as it is not mandatory but recommended by Studio 4.9 onwards, and android tools version is 25.3.0 or higher then on Create Android AVD page in Android preferences shows error

      Steps to Reproduce:
      1. Ensure JDK 1.8 is not installed
      2. Update Android SDK Tools to version above 25.3.0
      3. Go to Preferences -> Studio -> Platforms -> Android
      4. Click on Create AVDs button

      Actual Result:
      An error is shown "No Systems images have been found. Please configure via Android Studio."
      This is due to AVDManager tool requires minimum of JDK 1.8 and the same is used to fetch System Images
      Also refer to the attached screenshot

      Expected Result:
      The error should be handled or Create AVD allowed only if JDK 1.8 or higher is installed.

        Attachments

          Activity

            People

            • Assignee:
              ppedduri Prashanth Pedduri (Inactive)
              Reporter:
              ssekhri Satyam Sekhri
              Reviewer:
              Kondal Kolipaka (Inactive)
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: