Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8810

Downloads: Studio will prompt a user to download hyperloop 1.2.8 if they have no titanium sdk

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Duplicate
    • Affects Version/s: Release 4.9.0
    • Fix Version/s: None
    • Component/s: Hyperloop
    • Labels:
    • Environment:

      Appc Studio:4.9.0.201705302345
      Windows 10 Pro

      Description

      Description

      This might be an issue with the api call made by Studio, if so please move as appropriate

      When a user has no titanium SDK i.e a clean install, when Studio prompts them to install components it will ask them to install hyperloop 1.2.8. Below is the output of the command Studio runs appc platform downloads get -o json, the main version is listed as 1.2.8 which I guess is what Studio reads from?

      {
          "modules": [
              {
                  "oses": [
                      "linux",
                      "win32",
                      "osx"
                  ],
                  "platforms": [
                      "iphone",
                      "android"
                  ],
                  "required": true,
                  "partner_id": "A0B129A418829127EC551EB8ADB0D1CC",
                  "partner_name": "Appcelerator",
                  "name": "Hyperloop",
                  "description": "Gain complete access to native APIs in your Titanium mobile applications.",
                  "id": "hyperloop",
                  "guid": "99a136cd-4e51-40da-bcdb-d514f5895fb5",
                  "version": "1.2.8",
                  "url": "http://appcelerator-modules.s3.amazonaws.com/hyperloop-1.2.8.zip",
                  "min_mobilesdk_version": "5.4.0",
                  "versions": [
                      {
                          "platforms": [
                              "iphone",
                              "android"
                          ],
                          "sdk_versions": ">=5.4.0 <6.0.0",
                          "version": "1.2.8",
                          "url": "https://appcelerator-modules.s3.amazonaws.com/hyperloop-1.2.8.zip"
                      },
                      {
                          "platforms": [
                              "iphone",
                              "android"
                          ],
                          "sdk_versions": ">=6.0.0",
                          "version": "2.1.2",
                          "url": "https://appcelerator-modules.s3.amazonaws.com/hyperloop-2.1.2.zip"
                      }
                  ]
              }
          ],
          "components": []
      }
      

      Steps to reproduce
      1. Remove your sdks, by deleting them from the mobilesdk folder or renaming the mobilesdk folder
      2. Run Help->Check for Appcelerator Updates
      Actual

      Prompt gives hyperloop 1.2.8

      Expected

      Prompt should give latest hyperloop version

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                eharris Ewan Harris
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: