Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8808

Studio freezes on splash screen due to invalidated session

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Duplicate
    • Affects Version/s: Release 4.9.0
    • Fix Version/s: Release 4.10.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Studio: 4.9.0.201705302345
      OSX 10.12.5 (16F73) & Windows 10 1703 Pro
      Appc CLI: 6.2.2
      Appc NPM: 4.2.9

      Description

      Description

      When opening Studio it freezes on the splash, the progress bar is displaying 'Loading Studio' and is no longer moving and on mac it starts to 'beachball' and is classified as not responding
      Attached are logs from starting Studio from the console and the jstack output of that process.

      I fixed this by logging in so my assumption is that Studio is getting caught on me having and invalid session, I opened Studio over half a dozen times and this occurred, as soon as I logged in from the CLI it worked. I believe this might be widespread as I regularly see comments of 'appc login fixed Studio for me'

      Steps to reproduce
      1. Invalidate your CLI login session, this can be done by logging in on a different machine or removing your session and sid from ~/.appcelerator/appc-cli.json
      2. Open Studio, clicking the workspace prompt if it appears
      Actual

      Studio freezes on the splashscreen, logging in fixes the issue

      Expected

      Studio should not freeze

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ppedduri Prashanth Pedduri (Inactive)
                Reporter:
                eharris Ewan Harris
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: