Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8644

Installer: Node not installed when an unsupported version is installed

    Details

    • Story Points:
      2
    • Sprint:
      2016 Sprint 23 Studio

      Description

      Description

      When a user has an unsupported version of Node installed and they install Studio, the prerequisite check should pick up this version and install Node. Currently it does not and Node will not be installed through the installer. When the user then opens Studio it will install Node 4.6.0.

      Steps to reproduce
      1. Install Node@0.12.17 https://nodejs.org/download/release/v0.12.17/
      2. Install Studio from http://studio-jenkins.appcelerator.org/view/Master/job/appcelerator-installer-win-master/
      Actual result

      The prereq check will not install Node

      Expected result

      The prereq check should install Node

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                eharris Ewan Harris
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: