Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8635

iOS Debugger: JSCore: Debug on iOS breaks/halts at first line of app.js even without breakpoint

    Details

    • Type: Bug
    • Status: Open
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: Release 4.8.0
    • Fix Version/s: None
    • Component/s: Debugging
    • Labels:
    • Environment:

      Description

      When an app is debug on an iOS simulator/device, it breaks/halts at the first line of app.js (for both classic and alloy apps) even if there is no breakpoint added in any file.

      • The issue occurs with <use-jscore-framework> as true
      • The issue occurs for both Alloy and Classic apps

      Steps To Reproduce:
      1. Create a default classic or alloy app
      2. Add a breakpoint anywhere except the first line in app.js / add breakpoint in index.js of alloy app
      3. Debug on iOS sim or device

      Actual Result:
      The debugger hits the first line of app.js (in both classic and alloy app) even though no breakpoint is on that line.
      In case of alloy app click on Resume after that shows up source not found and hence debugging is blocked.

      Expected Result:
      The debugger should hit only the line with a breakpoint. If there are no breakpoints then it should just run without stopping at a particular line

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ssekhri Satyam Sekhri
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: