Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-861

Titanium Studio: Configuration Utility - A notification still requires the user to get Google APIs 7 and 8 even if the user's environment is still valid

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Invalid
    • Affects Version/s: Titanium Studio 1.0.7
    • Fix Version/s: None
    • Component/s: Configuration
    • Labels:
    • Environment:

      Titanium Studio, build: 1.0.7.201111182325, Mac OS X Lion

      Description

      Description: If Google APIs 7 and 8 does not exist on your computer, but you have Google APIs 10 and up installed (a valid environment), then Configuration Utility still requires you to install Google APIs 7 and 8.

      Steps to reproduce:
      1. Navigate to your <android sdk>/add-ons folder
      2. Move or delete Google API 7 and 8 only
      3. Open TiStudio
      4. Navigate to the Configure tab and click on "Let's get things set up!"
      5. Click on the Android logo

      Result: Utility displays the message: Add-On 'addon.+google.+apis.+7,addon.+google.+apis.+8' required
      Expected: The message should not be displayed if the user still has a valid environment.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sgibly Shalom Gibly
                Reporter:
                wluu Wilson Luu (Inactive)
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: