Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8554

Install: Studio does not check for 64-bit versions of Node

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.8.0
    • Fix Version/s: Release 4.8.0
    • Component/s: Installer
    • Labels:
    • Environment:

      Windows 10 Pro
      Studio: 4.8.0

    • Story Points:
      5
    • Sprint:
      2016 Sprint 22 Studio

      Description

      Description

      When writing TISTUD-8553 I noticed that it appears that Studio does not validate for 64-bit versions of Node, however this only happens on the 4.8.0 installer. The installers I have for the GA 4.7.0 and 4.6.0 Studios do not have this issue. I have had this happen before and it can cause problems with an install of the CLI.

      Steps to reproduce
      1. Uninstall all Node and Appcelerator Studio version
      2. Install a 64 bit Node from https://nodejs.org/en/download/
      3. Install 4.8.0 Studio from http://studio-jenkins.appcelerator.org/view/Development/job/appcelerator-installer-win-development/
      Actual result

      The install will install 32-bit Node, even though a 64-bit version exists

      Expected result

      Studio should not install

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              eharris Ewan Harris
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: