Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8472

Android: Building the app for genymotion emulator gives alert "The launch requires 2.3.3 SDK or higher"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 4.6.0
    • Fix Version/s: Release 4.8.0
    • Component/s: Android
    • Labels:
    • Environment:

      Environment:
      Appc Studio : 4.6.0.201604180847
      Ti SDK : 5.3.0.v20160420090405
      Ti CLI : 5.0.7
      Alloy : 1.8.5
      MAC El Capitan : 10.11.4
      Appc NPM : 4.2.5-3
      Appc CLI : 5.3.0-22
      Node: 4.2.2

    • Story Points:
      5
    • Sprint:
      2016 Sprint 13 Studio

      Description

      Steps to reproduce:

      1. Create an android app in appcelerator studio.
      2. Run it on genymotion emulator.

      Actual Results:

      1. As soon as you click run in studio you will get an alert:
      The launch requires Android 2.3.3 SDK or above. Would you like to update the launch configuration to the required version?
      2. I already have Android 2.3.3 installed but still see this alert.
      NOTE: This is only seen for the first time a newly created app is run on genymotion emulator.

      Expected Results:

      1. There should be no such alert.

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              lchoudhary Lokesh Choudhary
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: