Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8471

Android: Creating project with just android 6.0 platform installed studio shows a message "Android development requires [2.3.3,6.0)"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.6.0
    • Fix Version/s: Release 4.6.0
    • Component/s: Android
    • Labels:
    • Environment:

      Environment:
      Appc Studio : 4.6.0.201604180847
      Ti SDK : 5.3.0.v20160420090405
      Ti CLI : 5.0.7
      Alloy : 1.8.5
      MAC El Capitan : 10.11.4
      Appc NPM : 4.2.5-3
      Appc CLI : 5.3.0-22
      Node: 4.2.2

    • Story Points:
      3
    • Sprint:
      2016 Sprint 09 Studio

      Description

      Steps to reproduce:

      1. Make sure you have just android 6.0 platform SDK installed.(You can do it using Android SDK manager).
      2. Now in studio try to create a new mobile project.
      3. On the mobile app project window look at the android deployment targets.

      Actual Results:

      1. You will see a info icon next to android platform & hovering the mouse pointer over it shows message:
      Android development requires [2.3.3,6.0),but you have 6.0, 6.0, 6.0, 6.0, 6.0, 6.0
      2. Attaching screenshot for reference.

      Expected Results:

      1. You should not see any message & should support project creation etc with just Android 6.0 installed.

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              lchoudhary Lokesh Choudhary
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: