Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8469

Studio: Unable to update studio due to dependency issues.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: App Designer
    • Labels:
    • Environment:

      Mac OSX El Capitan 10.11.4
      Studio: 4.6.0.201604141457
      Ti SDK: 5.3.0.v20160415121959
      Appc NPM: 4.2.5-2
      App CLI: 5.3.0-12
      Node v4.4.2

    • Story Points:
      5
    • Sprint:
      2016 Sprint 08 Studio

      Description

      When I try to update studio http://studio-jenkins.appcelerator.org/job/appcelerator-rcp-development/lastSuccessfulBuild/artifact/dist/ from version GA to the current jenkins build 4.6.0.201604180847 an error is thrown and the update is unsuccessful.

      Steps to reproduce:

      1. Downloaded the GA of studio
      2. Added AppDesigner from labs using the url: https://preview.appcelerator.com/appcelerator/labs/appdesigner/update/beta/
      3. Once AppDesigner has been installed I update studio using the development branch: http://studio-jenkins.appcelerator.org/job/appcelerator-rcp-development/lastSuccessfulBuild/artifact/dist/
      4. This is when I see the error in the image.

      Actual :
      See image below

      Your original request has been modified.
        "Appcelerator Designer" is already installed, so an update will be performed instead.
      Cannot complete the install because of a conflicting dependency.
        Software being installed: Appcelerator Designer 1.0.6 (VisualUIFeature.feature.group 1.0.6)
        Software currently installed: Appcelerator Studio 4.6.0.201604130502-13042016050308 (com.appcelerator.titanium.rcp.product 4.6.0.201604130502-13042016050308)
        Only one of the following can be installed at once: 
          Appcelerator Designer 1.0.5.9 (VisualUIFeature.feature.jar 1.0.5.9)
          Appcelerator Designer 1.0.6 (VisualUIFeature.feature.jar 1.0.6)
        Cannot satisfy dependency:
          From: Appcelerator Designer 1.0.5.9 (VisualUIFeature.feature.group 1.0.5.9)
          To: VisualUIFeature.feature.jar [1.0.5.9]
        Cannot satisfy dependency:
          From: Appcelerator Designer 1.0.6 (VisualUIFeature.feature.group 1.0.6)
          To: VisualUIFeature.feature.jar [1.0.6]
        Cannot satisfy dependency:
          From: Appcelerator Studio 4.6.0.201604130502-867nFNNFH1kUeGD5II1bz-HOKIz0 (com.appcelerator.titanium.feature.360.rcp.feature.group 4.6.0.201604130502-867nFNNFH1kUeGD5II1bz-HOKIz0)
          To: VisualUIFeature.feature.group [1.0.5.9]
        Cannot satisfy dependency:
          From: Appcelerator Studio 4.6.0.201604130502-13042016050308 (com.appcelerator.titanium.rcp.product 4.6.0.201604130502-13042016050308)
          To: com.appcelerator.titanium.feature.360.rcp.feature.group [4.6.0.201604130502-867nFNNFH1kUeGD5II1bz-HOKIz0]
      

      Expected:
      Studio is updated.

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              jlongton Josh Longton
            • Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: