Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8467

Studio: Ability to set Windows SDK used to package app

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.6.0
    • Fix Version/s: Release 4.7.0
    • Component/s: Windows
    • Labels:
    • Environment:

      Windows 10 Pro
      Appc Studio: 4.6.0.201604141457

    • Story Points:
      5
    • Sprint:
      2016 Sprint 12 Studio

      Description

      Description

      We need to be able to allow a user to set the Windows SDK used to package a Windows Platform app, currently the user is unable to set this in Studio and by default the app will be packaged with 8.1

      [TRACE] :  ExpandSDKReferences:
        Enumerating SDK Reference "Microsoft.VCLibs, Version=12.0" from "C:\Program Files (x86)\Microsoft SDKs\WindowsPhoneApp\v8.1\ExtensionSDKs\Microsoft.VCLibs\12.0\".

      Steps to reproduce

      1. On a Windows machine select Package->Windows->Windows Phone

      Actual result

      You are only able to select the output location, 8.1 SDK is used

      Expected result

      User should be able to select a Windows SDK they would like to package an app with

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                eharris Ewan Harris
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: