Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8447

Windows: Studio needs to specify the Windows SDK to be used when building to a Windows 10 emulator

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.5.0
    • Fix Version/s: Release 4.6.0
    • Component/s: Windows
    • Labels:
    • Environment:

      Windows 10 Pro
      Appc NPM: 4.2.4-2
      Appc Core: 5.2.1-20
      Titanium SDK: 5.3.0.v20160318230005
      Appc Studio: 4.5.0.201602170821

    • Story Points:
      5
    • Sprint:
      2016 Sprint 08 Studio

      Description

      Description

      When building to a Windows 10 Mobile emulator using the following command appc run -p windows -T wp-emulator -C 10-0-6 currently this will error out with the below until TIMOB-20571 is done as the CLI will use the 8.1 SDKs by default

      [ERROR] Invalid "--device-id" value "10-0-6"
       
      For help, run: titanium.js help build
      

      When building to the a Windows 10 Mobile emulator Studio should also add --wp-sdk 10.0 otherwise the build will fail

      Steps to reproduce

      1. Build to a Windows 10 Emulator using Studio

      Actual result

      The build will fail with the below

      [ERROR] Invalid "--device-id" value "10-0-6"
       
      For help, run: titanium.js help build
      

      Expected result

      The build should not fail

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Christopher Williams
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: