Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-8006

Studio/CLI does not allow you run (HL example) with demo GUID


    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 4.5.0
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
    • Environment:

      Appcelerator Studio - 4.5.0
      Appcelerator CLI - 5.2.0
      Titanium SDK - 5.2.0.GA
      Xcode - 7.2.1
      iOS - 9.2 (Simulator)
      OSX - El Captain
      Hyperloop - 1.1.0


      The HL module is currently configured to require the app to be registered under the platform or use the demo GUID (11111111-1111-1111-1111-111111111111) as long as you use the development deployType.

      However, both Studio and the Unified CLI are configured to not allow the demo GUID plus they seem to validate registered guids in a different way. So the only way to to run with that guid is to use OSS Titanium CLI.

      We need to:

      • Remove the restriction from the HL module
      • And/or make sure Studio/CLI and HL validate platform guids in the same way
      • And/or apply the same exception for development deployType to the Studio/Unified CLI logic

      I'd also think we should better move the logic from Studio to the CLI so we have a single point of failure.

      Original description

      I have an existing titanium application (already registered under appcelerator platform under team subscription).

      Upgraded to 5.2.0.GA to experiment Hyperloop features. Downloaded Hyperloop (1.1.0) from appcelerator labs, configured both plugin and module. Now when I run the project, I get a alert saying, Hyperloop is not enabled as this project is not registered under appcelerator platform.

      When I tried using the demo GUID (11111111-1111-1111-1111-111111111111), it doesn't even allow the app to be compiled, console says "Application not registered".

      Even tried appc new --import from project root, but still no luck. Is this a issue with CLI or SDK?




            • Assignee:
              cwilliams Christopher Williams
              mano_mykingdom Manojkumar Murugesan
            • Watchers:
              4 Start watching this issue


              • Created: