Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7967

SSL certificate error When customer try to login from Studio.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Login
    • Labels:
      None
    • Environment:

      CLI 5.1.0

      Description

      One of customers facing this problem:

      1. He can do appc login and appc logout from command line.
      2. But If he try to open the studio directly and login from studio, it will get a SSL certificate error. attached screen shot.

      Here is the error log:

      _________________________________________________________ 
      !ENTRY com.appcelerator.titanium.360.core 4 0 2016-01-18 19:39:53.912 
      !MESSAGE (Build 3.4.1.1413590581) [ERROR] Request: login to https://dashboard.appcelerator.com, params: xxxx@xxxx.com, ********** 
      !STACK 0 
      javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated 
      at com.sun.net.ssl.internal.ssl.SSLSessionImpl.getPeerCertificates(SSLSessionImpl.java:352) 
      at org.apache.http.conn.ssl.AbstractVerifier.verify(AbstractVerifier.java:128) 
      at org.apache.http.conn.ssl.SSLSocketFactory.connectSocket(SSLSocketFactory.java:572) 
      at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:180) 
      at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:294) 
      at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:640) 
      at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:479) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:906) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:805) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:784) 
      at com.appcelerator.appc360.API.login(API.java:125) 
      at com.appcelerator.titanium360.internal.core.Titanium360Manager.login(Titanium360Manager.java:167) 
      at com.appcelerator.titanium360.internal.core.Titanium360Manager.checkLoginUser(Titanium360Manager.java:612) 
      at com.appcelerator.titanium.rcp.handlers.TitaniumSplashHandler$12.run(TitaniumSplashHandler.java:693) 
      (Build 3.4.1.1413590581) [ERROR] Request: login to https://dashboard.appcelerator.com, params: xxxx@xxxx.com, ********** 
      javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated 
      at com.sun.net.ssl.internal.ssl.SSLSessionImpl.getPeerCertificates(SSLSessionImpl.java:352) 
      at org.apache.http.conn.ssl.AbstractVerifier.verify(AbstractVerifier.java:128) 
      at org.apache.http.conn.ssl.SSLSocketFactory.connectSocket(SSLSocketFactory.java:572) 
      at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:180) 
      at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:294) 
      at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:640) 
      at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:479) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:906) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:805) 
      at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:784) 
      at com.appcelerator.appc360.API.login(API.java:125) 
      at com.appcelerator.titanium360.internal.core.Titanium360Manager.login(Titanium360Manager.java:167) 
      at com.appcelerator.titanium360.internal.core.Titanium360Manager.checkLoginUser(Titanium360Manager.java:612) 
      at com.appcelerator.titanium.rcp.handlers.TitaniumSplashHandler$12.run(TitaniumSplashHandler.java:693)
      

      Here is the detail based on his response

      1. No proxy
      2. OS X Yosemite version 10.10.1
      3. Studio was working well until I restarted Studio. No changes to the OS or any software were made prior to the receiving the error.

      Please suggest a way to solve this, and why this happened?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                sliang Shuo Liang
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: