Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7796

If you run "npm ls -g appcelerator" when a pre-release version is installed, "npm ERR! code 1" is returned

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 4.3.3
    • Component/s: Node
    • Labels:
    • Environment:

      Appc CLI NPM: 4.2.1-5
      Appc CLI Core: 5.0.4-2
      Arrow: 1.2.62
      Node: 0.12.7, 4.2.1
      OS: El Capitan (10.11)

    • Story Points:
      5
    • Sprint:
      2015 Sprint 21 Studio

      Description

      Details: If you run "npm ls -g appcelerator", "npm ERR! code 1" is returned.

      Note:

      • This issue does not occur with Node 0.10.38.

      Steps to reproduce:

      1. Make sure you have Node 4.X.X or 0.12.X
      2. Install Appc CLI NPM: sudo npm install -g appcelerator@4.2.1-5. It HAS to be a pre-release (including a -X in the version #)
      3. Next, run the following command in your ~ path: npm ls -g appcelerator

      Actual: The following error is returned:

      WilsonComputer:~ wluu$ npm ls -g appcelerator
      npm WARN unmet dependency /usr/local/lib/node_modules/gittio/node_modules/update-notifier requires request@'^2.36.0' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/gittio/node_modules/request,
      npm WARN unmet dependency which is version 2.30.0
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npmconf requires semver@'2' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/semver,
      npm WARN unmet dependency which is version 5.0.3
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npmconf requires uid-number@'0.0.5' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/uid-number,
      npm WARN unmet dependency which is version 0.0.6
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data requires semver@'2 || 3' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/semver,
      npm WARN unmet dependency which is version 5.0.3
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npm-registry-client/node_modules/npm-package-arg requires semver@'4' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/semver,
      npm WARN unmet dependency which is version 5.0.3
      /usr/local/lib
      └── (empty)
       
      npm ERR! code 1
      

      Expected: No error should be returned when you run npm ls -g appcelerator.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                wluu Wilson Luu (Inactive)
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: