Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7795

Studio Installer: Later appcelerator core and NPM versions are overwritten by GA versions by installer

    Details

    • Type: Bug
    • Status: Open
    • Priority: None
    • Resolution: Unresolved
    • Affects Version/s: Release 4.3.3
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:
    • Environment:

      NPM Version: 2.14.7
      Node Version: 4.2.1
      Mac OS: 10.10.5
      Appc CLI: 5.0.4-2
      Appc CLI NPM: 4.1.0-2
      Titanium SDK version: 5.1.0.v20151019145227
      Appcelerator Studio, build: 4.3.3.201510201834
      Xcode 7 GM

      Description

      Description:

      The studio installer overwrites development versions of the CLI core and NPM with the GA versions. I started with Appc CLI NPM: 4.2.1-5 and Appc CLI Core: 5.0.4-2 and after install I had: Appc CLI NPM: 4.2.0 and Appc CLI Core: 5.0.3.

      The installer should not overwrite versions later than the GA with the GA versions.

      Steps to reproduce:

      1) Install Appc CLI NPM: 4.2.1-5 and Appc CLI Core: 5.0.4-2
      2) Download and launch the installer for Studio 4.3.3.201510201834
      3) Note versions of installed components

      Result:

      The development versions are overwritten

      Expected Result:

      The development versions should not be overwritten

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: