Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7791

Studio prompts for update to incorrect NPM Appc CLI and SDK

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.3.3
    • Fix Version/s: Release 4.3.3
    • Component/s: None
    • Labels:
    • Environment:

      Mac OS 10.10.5
      Appc CLI: 5.0.4-2
      Appc CLI NPM: 4.1.0-2
      Titanium SDK version 5.1.0.v20151019145227
      Appcelerator Studio, build: 4.3.3.201510172433
      Xcode 7 GM

    • Story Points:
      5
    • Sprint:
      2015 Sprint 21 Studio

      Description

      Description:

      When installing the pre-release version of Studio 4.3.3.201510172433, you are prompted to install the 4.0.1-rc2 version of the Appcelerator CLI NPM package. You are also prompted to install SDK 5.2.0.x. Studio should check for <GA and prompt for that, but if >GA, there should be no prompt.

      Steps to reproduce:

      1) Install studio 4.3.3.201510172433
      2) Check for appcelerator updates
      3) Note versions offered

      Result:

      SDK and Appc CLI NPM are presented, but not versions that are needed for the beta release.

      Expected Result:

      Neither component offered if on GA version or greater

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              emerriman Eric Merriman
              Reviewer:
              Kondal Kolipaka (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: