Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7538

Default URL for tiapp.xml valid in wizard but invalid in editor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 4.5.0
    • Component/s: Editor, Projects, Tiapp
    • Labels:
    • Environment:

      Studio 4.0.0.201505202026 (GA)

    • Story Points:
      5
    • Sprint:
      2015 Sprint 17 Studio, 2015 Sprint 24 Studio

      Description

      The default value for Company/Personal URL field in the new project wizard is http://. When you remove it to be empty it will tell you it is required, but leaving it to the default does not trigger any errors here.

      But once the project is created and the Tiapp Editor opens, it will show an error in the XML-view.

      See the attached screenshots

      Expected

      I'd expect the error to be raised in the new project wizard as well.

      Also, I think this field should not be required and empty by default.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kkolipaka Kondal Kolipaka (Inactive)
                Reporter:
                fokkezb Fokke Zandbergen
                Reviewer:
                Praveen Innamuri (Inactive)
              • Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: