Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7522

If you update Appc Studio, Appc Studio will not understand Appc CLI 4.0.0-rc

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.0.0
    • Fix Version/s: Release 4.0.0
    • Component/s: Update
    • Labels:
    • Environment:

      Appcelerator Studio, build: 4.0.0.201505191245
      Appc CLI NPM: 4.0.0-rc
      Appc CLI Registry: 4.0.0-rc
      Arrow: 0.3.210
      SDK: 4.0.0.RC5
      Node: v0.10.36
      OS: Yosemite (10.10.3)

    • Story Points:
      5
    • Sprint:
      2015 Sprint 10 Studio

      Description

      Details: Currently, if you update Appc Studio, Studio will try to update Appc CLI to 4.0.0 even though Appc CLI does not exist. This is because Appc Studio cannot recognize 4.0.0-rc.

      Steps to reproduce:

      1. Update Appc Studio on the RC stream

      Actual: Appc Studio will try to update to Appc CLI 4.0.0 even though it does not exist; see attachment.

      Expected: Appc Studio should be able to recognize Appc CLI 4.0.0-rc.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                wluu Wilson Luu (Inactive)
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: