Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7490

Studio should use appc run rather than appc ti build

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.0.0
    • Fix Version/s: Release 4.0.0
    • Component/s: Build
    • Labels:
    • Environment:

      Mac OSX 10.10.3
      Appc Studio: 4.0.0.201505070727
      Titanium SDK build: 4.0.0.v20150508112613
      Appc CLI (NPM): 0.3.55
      Appc CLI (Registry): 0.2.282

      Description

      Description

      Currently Studio is using the following commands when building

      "/usr/local/bin/appcelerator" "ti" "build" "--platform" "ipad" "--log-level" "trace" "--sdk" "4.0.0.Beta2" "--project-dir" "/Users/eharris/Documents/Appcelerator_Studio_Workspace/ProdEnterpriseApp" "--target" "simulator" "--ios-version" "8.2" "--device-family" "universal" "--deploy-type" "development" "--sim-type" "ipad" "--sim-version" "8.2" "--device-id" "9EF4205F-E350-4767-9CEF-B168C11A52C1" "--skip-js-minify" "--no-colors" "--no-progress-bars" "--no-prompt" "--prompt-type" "socket-bundle" "--prompt-port" "49629"
      

      It should move to using appc run over appc ti build

      Steps To Reproduce

      1. In Studio build a project
      2. Check the logs

      Actual Result

      Studio will be using appc ti build

      Expected Result

      Studio should be using appc run

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Kondal Kolipaka (Inactive)
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: