Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:
      None
    • Environment:

      Studio VERSION 3.4.2.201502181619
      BUILD 201502181619
      Mac OS Yosemite

      Description

      User is getting error while installing Appcelerator Studio in a new computer:

      !SESSION 2015-03-30 15:59:46.237 ----------------------------------------------- 
      eclipse.buildId=unknown 
      java.version=1.6.0_65 
      java.vendor=Apple Inc. 
      BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US 
      Framework arguments: -keyring /Users/ja316153/.eclipse_keyring -showlocation 
      Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/ja316153/.eclipse_keyring -consoleLog -showlocation 
       
      !ENTRY org.eclipse.core.net 1 0 2015-03-30 16:00:24.952 
      !MESSAGE System property http.nonProxyHosts has been set to local|*.local|169.254/16|*.169.254/16 by an external source. This value will be overwritten using the values from the preferences 
       
      !ENTRY org.eclipse.ui 2 0 2015-03-30 16:00:25.146 
      !MESSAGE Warnings while parsing the images from the 'org.eclipse.ui.commandImages' extension point. 
      !SUBENTRY 1 org.eclipse.ui 2 0 2015-03-30 16:00:25.146 
      !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.run_on_device.android' 
      !SUBENTRY 1 org.eclipse.ui 2 0 2015-03-30 16:00:25.147 
      !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.debug_on_device.android' 
       
      !ENTRY com.aptana.scripting 4 0 2015-03-30 16:00:26.235 
      !MESSAGE (Build 3.4.2.201502181619) [ERROR] Failed to load bundle /Applications/Appcelerator_Studio/plugins/com.appcelerator.titanium.core_3.1.2.1410892015/bundles/titanium_mobile.ruble 
      !STACK 0 
      Can't construct a java object for !ruby/object:Ruble::Bundle; exception=Invalid tag: !ruby/object:Ruble::Bundle 
      in "<reader>", line 1, column 5: 
      --- !ruby/object:Ruble::Bundle 
      ^ 
       
      at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.construct(Constructor.java:325) 
      at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseConstructor.java:181) 
      at org.yaml.snakeyaml.constructor.BaseConstructor.constructDocument(BaseConstructor.java:140) 
      at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:126) 
      at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:296) 
      at org.yaml.snakeyaml.Yaml.load(Yaml.java:290) 
      at com.aptana.scripting.model.BundleCacher.load(BundleCacher.java:328) 
      at com.aptana.scripting.model.BundleCacher.load(BundleCacher.java:286) 
      at com.aptana.scripting.model.BundleManager$BundleLoadJob.run(BundleManager.java:110) 
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53) 
      Caused by: org.yaml.snakeyaml.error.YAMLException: Invalid tag: !ruby/object:Ruble::Bundle 
      at org.yaml.snakeyaml.nodes.Tag.getClassName(Tag.java:108) 
      at org.yaml.snakeyaml.constructor.Constructor.getClassForNode(Constructor.java:620) 
      at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.getConstructor(Constructor.java:313) 
      at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.construct(Constructor.java:323) 
      ... 9 more 
      !SESSION 2015-03-30 16:11:14.943 ----------------------------------------------- 
      eclipse.buildId=unknown 
      java.version=1.6.0_65 
      java.vendor=Apple Inc. 
      BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US 
      Framework arguments: -keyring /Users/ja316153/.eclipse_keyring -showlocation 
      Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/ja316153/.eclipse_keyring -consoleLog -showlocation 
       
      !ENTRY org.eclipse.core.net 1 0 2015-03-30 16:11:17.627 
      !MESSAGE System property http.nonProxyHosts has been set to local|*.local|169.254/16|*.169.254/16 by an external source. This value will be overwritten using the values from the preferences 
       
      !ENTRY org.eclipse.ui 2 0 2015-03-30 16:11:17.801 
      !MESSAGE Warnings while parsing the images from the 'org.eclipse.ui.commandImages' extension point. 
      !SUBENTRY 1 org.eclipse.ui 2 0 2015-03-30 16:11:17.801 
      !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.run_on_device.android' 
      !SUBENTRY 1 org.eclipse.ui 2 0 2015-03-30 16:11:17.801 
      !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.debug_on_device.android'
      

      Expected behavior

      Be able to install and launch Appcelerator Studio with no issue

      Additional comment from customer

      I'm now on Yosemite, though had the same issue on Mavericks. It's a clean install, though when I installed last week, it ran fine Thursday/Friday, but stopped working sometime Friday. Since then, no amount of uninstall/reinstall has corrected the issue.

      I downloaded the 64-bit ZIP from the Appc Dashboard, and have also tried the 32-bit install.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ingo Ingo Muschenetz
                Reporter:
                rtlechuga Radamantis Torres-Lechuga (Inactive)
              • Watchers:
                4 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved: