Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7047

Studio should parse minimum required version of nodejs package from a feed

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Medium
    • Resolution: Duplicate
    • Affects Version/s: Release 3.4.1
    • Fix Version/s: None
    • Component/s: Node, Update
    • Labels:
      None

      Description

      Currently Studio assumes that NodeJS v0.10.13 is the minimum required version and if the user doesn't have at least this version, then it prompt the user for update.

      However, if the minimum required version is changed by SDK or any titanium npm packages, then Studio will not be aware of the minimum required version. We need to include a feed that contains the minimum required version for nodejs and Studio should rely on that to parse the minimum version. Also, we might need to consider about updating the nodejs installer from server.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                pinnamuri Praveen Innamuri (Inactive)
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: