Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-7017

Studio 32-bit: Java 1.7 - Cannot launch 32-bit Studio if you only have Java 1.7

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Won't Fix
    • Affects Version/s: Release 3.4.0
    • Fix Version/s: None
    • Component/s: Setup, Usability
    • Labels:
    • Environment:

      Appcelerator Studio, build: 3.4.0.201409261245
      OS: Yosemite (10.10 GM Candidate)
      Java: 1.7.0_65

      Description

      Details: You cannot launch AppcStudio 32-bit if you only have Java 1.7 on your machine.

      Notes:

      • To work around this, you can use AppcStudio 64-bit or download and install Java 1.6 from here: http://support.apple.com/kb/DL1572
      • I got into this situation when I was installing Yosemite on one my partitions and selected the option to migrate my system files and applications from my Mavricks partition. My Mavricks partition has both Java 1.6 and 1.7, but looks like the Yosemite migration option took the latest Java.

      Steps to reproduce:
      1. Make sure you only have Java 1.7 on your machine; you can remove Java 1.6 at: /System/Library/Java/JavaVirtualMachines
      2. Download and install AppcStudio 32-bit; the dmg installer

      Actual: You will not be able to launch AppcStudio 32-bit; see attachments.
      Expected: You should be able to launch AppcStudio 32-bit with only Java 1.7

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ingo Ingo Muschenetz
                Reporter:
                wluu Wilson Luu (Inactive)
              • Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: