Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6946

AppcStudio: Update - If you update your studio using the wrong stream, then you will get an "-10810" error

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: Release 3.3.0
    • Fix Version/s: None
    • Component/s: Usability
    • Labels:
    • Environment:

      Appcelerator Studio, build: 3.3.0.201407111535

      Description

      Details: If you update your studio using the wrong stream, then you will get an "-10810" error.

      Steps to reproduce:
      1. Open AppcStudio; preferably, a studio version that is in the wild
      2. Go to Appcelerator Studio > Preferences... > Install/Update > Available Software Sites
      3. Click on Add button
      4. Specify a name and use a Titanium Studio RC stream for Location e.g. http://preview.appcelerator.com/appcelerator/studio/standalone/update/rc/
      5. Press OK, reload the stream, then press OK again to dismiss the window
      6. Next, go to Help > Check For Appcelerator Updates
      7. Accept the new build via wizard
      8. Allow Studio to restart; this should fail
      9. Then, double-click on AppcStudio icon

      Actual: You will get the "-10810" error message; see attachment.
      Expected: You should not get the error message if using a different stream to update Studio.

        Attachments

          Activity

            People

            • Assignee:
              ingo Ingo Muschenetz
              Reporter:
              wluu Wilson Luu (Inactive)
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: