Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6919

Studio doesn't check Node, NPM updates if it's outdated.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: None
    • Resolution: Duplicate
    • Affects Version/s: Release 3.4.0
    • Fix Version/s: None
    • Component/s: Node, Update, Usability
    • Labels:
    • Environment:

      Description

      Studio doesn't detect outdated Node and NPM installations when we check for Appcelerator updates.
      It's only detecting if Node in not installed.
      This is not a regression because of same behavior in 3.3.0 as well.

      Steps To Reproduce

      1. Revert your Node and NPM module (I installed Node v0.7.8 and NPM 1.1.18)
      2. Open Studio and check for updates

      Actual Result

      Outdated node and npm s are not triggered for update. Please see the attachment Node_Update.png for more info.

      Expected Result

      Node and NPM should be detected and updated successfully for latest available version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                kvelummaylum Kajenthiran Velummaylum
                Tester:
                Kajenthiran Velummaylum
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: