Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6904

Code Processor: Code Processor is not working if there is no Android SDK installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Won't Fix
    • Affects Version/s: Release 3.4.0
    • Fix Version/s: None
    • Component/s: Code Processor
    • Labels:
    • Environment:
    • Story Points:
      5

      Description

      Code Processor is not working If I don't have Android SDK set up on my machine.
      This is not a regression since issue is there in 3.3.0 GA as well.

      Steps To Reproduce

      1. Remove the Android SDK path from your Studio Preferences
      (Studio should not detect any Android SDK from your machine)
      2. Create a project
      3. Run code Analyze for any platform (iPhone or Mobileweb)

      Actual Result

      Code Processor fails with an error message. Please see the attachment.
      Following log entry is observed in Studio log file

      !ENTRY com.appcelerator.titanium.codeprocessor.core 4 0 2014-09-10 17:24:12.097
      !MESSAGE [ERROR] :  No valid Android SDK targets found.
      [ERROR] :  Please download an Android SDK target API level 14 or newer from the Android SDK Manager and try again.
       

      Expected Result

      It should generate proper html report.

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              kvelummaylum Kajenthiran Velummaylum
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: