Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6898

Studio: Option to build for iOS8 sim is available when on Xcode5 and 3.3.0 SDK

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.4.0
    • Fix Version/s: Release 3.4.0
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Mac OSX 10.9.4
      Appcelerator Studio, build: 3.4.0.201409032106
      Titanium SDK build: 3.3.0
      Titanium CLI, build: 3.4.0-beta
      Alloy: 1.5.0-beta2
      Xcode5

    • Story Points:
      3
    • Sprint:
      2014 Sprint 18 Studio

      Description

      Description

      When Xcode5 is selected and 3.3.0.GA SDK is selected in the tiapp.xml I still see an option to build to an iOS8 simulator in the menus.

      Steps To Reproduce

      1. In a projects tiapp.xml change the SDK version to 3.3.0.GA and in the terminal use the following command with your path to Xcode5 to switch to Xcode5

      sudo xcode-select -s *path to Xcode5*
      

      2. Go to build to an iOS simulator.

      Actual Result

      You should see the same as the attached screenshot.

      Expected Result

      There should only be iOS 7.1.

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              eharris Ewan Harris
              Tester:
              Visalakshi Chidambaram
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: