Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6873

Backward Compatibility: Studio 3.3.0 stop recognising iOS SDK if SDK 3.4.0 build is installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: Release 3.4.0
    • Fix Version/s: None
    • Component/s: Configuration
    • Labels:
    • Environment:

      Appcelerator Studio: 3.3.0.201407111535
      sdk: 3.3.0.GA, 3.4.0.v20140829184521
      acs: 1.0.16
      alloy: 1.4.1
      npm: 1.3.2
      titanium: 3.3.0
      titanium-code-processor: 1.1.1
      Xcode: 5.1.1
      OS: Mavericks 10.9.4

      Description

      Steps -
      1. Had configured latest 3.4.0 RC configuration on the system including Xcode6beta6 and CLI 3.4.0.
      2. Now wanted to revert back to 3.3.0 GA environment.
      3. Switched back Xcode to version 5.1.1
      4. Uninstalled 3.4.0 CLI and installed 3.3.0 CLI.
      5. Uninstalled 1.5.0 Alloy and installed 1.4.1 Alloy.
      6. Launched Appcelerator Studio 3.3.0

      Actual Result - Shows error message regarding iOS SDK configuration and observed that dashboard stop detecting iOS SDK. See the attached screen shots and Studio log file.

      Expected Result - Studio should detect the iOS SDK without any error message.

        Attachments

        1. ErrorScreenshot.png
          ErrorScreenshot.png
          30 kB
        2. ScreenShot1.png
          ScreenShot1.png
          30 kB
        3. ScreenShot2_Dashboard.png
          ScreenShot2_Dashboard.png
          127 kB
        4. ScreenShot3_Preference.png
          ScreenShot3_Preference.png
          68 kB
        5. StudioLog.txt
          9 kB

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              djha Dhirendra Jha
            • Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: