Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6815

Studio does not recognize installed npm packages if there are unmet dependencies with npm

    Details

    • Story Points:
      5
    • Sprint:
      2014 Sprint 24 Studio

      Description

      When I look for updates in 3.3.0 Appcelerator Studio, it did not recognize any installed npm packags and prompted to force install all of those npm updates.

      Studio runs npm ls <package> command to figure out the installed location and if there any errors in the output, then we fails to parse out the warnings/errors from the output. When I ran the below command, I realized that 'jake' npm package has certain issues with dependencies on the machine.

      $ "/usr/local/bin/node" "/usr/local/bin/npm" "ls" "alloy" "--color" "false" "-g"
      npm WARN unmet dependency /usr/local/lib/node_modules/jake/node_modules/filelist requires minimatch@'^0.3.0' but will load
      npm WARN unmet dependency /usr/local/lib/node_modules/jake/node_modules/minimatch,
      npm WARN unmet dependency which is version 0.2.14
      /usr/local/lib
      └── alloy@1.5.0-dev  (git://github.com/appcelerator/alloy.git#23da3c86415437cafec5a4f7385ecb52455893b8)
      

        Attachments

          Activity

            People

            • Assignee:
              smishra Sujeet Mishra
              Reporter:
              pinnamuri Praveen Innamuri (Inactive)
              Reviewer:
              Christopher Williams
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: