Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6519

"--vpc-type" passed to CLI instead of "--build-type" for VPC users

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: Release 3.3.0
    • Fix Version/s: Release 3.3.0
    • Component/s: Build
    • Labels:
    • Environment:

      Mac OS 10.9.3
      Xcode 5.1.1
      CLI: 3.3.0-alpha2
      Alloy: 1.4.0
      Titanium SDK version 3.3.0.v20140516180912
      Appcelerator Studio, build: 3.3.0.201405161313

      Description

      Description:

      When trying to build in a custom VPC environment, Studio sends a command to the CLI with the wrong flag. See below for example:

       
      Process: "/usr/local/bin/titanium" "--no-colors" "--no-progress-bars" "--no-prompt" "build" "--platform" "iphone" "--log-level" "trace" "--sdk" "3.3.0.v20140512162513" "--target" "simulator" "--ios-version" "7.1" "--device-family" "universal" "--sim-version" "7.1" "--deploy-type" "development" "--sim-type" "iphone" "--device-id" "iPhone Retina (4 inch 64-bit)" "--skip-js-minify" "--skip-js-minify" "--vpc-type" "536941428bfa54ce2ba33978"
      

      Steps to reproduce:

      1) Configure to use multi environment VPC
      2) Create a new project
      3) select a VPC in the Tiapp.xml
      4) Build the project
      5) Check the log

      Result:

      The Studio command for the CLI sues the wrong flag.

      Expected Result:

      "--build-type" passed to CLI.

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: