Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-6029

Automatically set the active SDK for CLI to the latest stable version after update

    Details

    • Story Points:
      3

      Description

      Currently when Studio updates SDK to the latest stable version, running "ti sdk" from command line still shows the previous SDK as selected. This could cause issues since we don't pass in "--sdk <version>" for all the commands, and when it's not, CLI will use the one set as active and could return inaccurate information. So we should call "ti sdk select <version>" after update.

      For custom SDK installed from a URL, we should not update the selected SDK since it may not be stable and fully tested.

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              mxia Michael Xia
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: