Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-597

Install from URL does not extract and maintain symbolic links

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Titanium Studio 1.0.4
    • Fix Version/s: Titanium Studio 1.0.6
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OS X

      Description

      We currently have a bug in Desktop where users who install a SDK via the "install from URL" option.
      It appears the extraction logic in Studio does not restore symbolic links.

      Wrong:

      drwxr-xr-x   6 user  staff  204 Aug 18 18:18 .
      drwxr-xr-x  27 user  staff  918 Aug 18 18:18 ..
      -rwxr-xr-x   1 user  staff   31 Aug 18 18:18 PrivateHeaders
      -rwxr-xr-x   1 user  staff   26 Aug 18 18:18 Resources
      drwxr-xr-x   4 user  staff  136 Aug 18 18:18 Versions
      -rwxr-xr-x   1 user  staff   24 Aug 18 18:18 WebCore
      

      Correct (notice links point to correct locations):

      drwxr-xr-x  6 user  staff  204 Aug  1 11:33 .
      drwxr-xr-x  6 user  staff  204 Aug  1 11:33 ..
      lrwxr-xr-x  1 user  staff   31 Aug  1 11:52 PrivateHeaders -> Versions/Current/PrivateHeaders
      lrwxr-xr-x  1 user  staff   26 Aug  1 11:52 Resources -> Versions/Current/Resources
      drwxr-xr-x  4 user  staff  136 Aug  1 11:33 Versions
      lrwxr-xr-x  1 user  staff   24 Aug  1 11:52 WebCore -> Versions/Current/WebCore
      

        Attachments

          Activity

            People

            • Assignee:
              mstepanov Max Stepanov
              Reporter:
              joshroesslein Josh Roesslein
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: