Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5841

Running a iPad only app on iPad simulator starts the app in iphone simulator

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 3.2.0
    • Fix Version/s: 2013 Sprint 25, Release 3.2.0
    • Component/s: iOS
    • Labels:
      None
    • Environment:
    • Story Points:
      5

      Description

      When trying to build a iPad only app for iPad simulator using SDK 3.1.2.GA on the latest Studio kicks of a iphone simulator build.

      studio log

      !ENTRY com.aptana.core 1 0 2013-12-04 10:58:00.059
      !MESSAGE (Build 3.2.0.201311271528) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/local/bin/titanium" "--no-colors" "--no-progress-bars" "--no-prompt" "build" "--platform" "ipad" "--sdk" "3.1.2.GA" "--log-level" "trace" "--target" "simulator" "--ios-version" "7.0" "--device-family" "iphone" "--skip-js-minify" `
      

      Steps to Reproduce.

      1. Create a new iPad only app with SDK set 3.1.2.GA
      2. Run for iPad Simulator.

      Actual Result.
      iphone simulator starts up.

      Expected Result.
      Selected iPad simulator starts up.

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              srahim Sabil Rahim
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: