Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5747

iOS 7.1 beta: Studio does not recognize Xcode 5.1 DP

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2013 Sprint 24, Release 3.2.0
    • Component/s: iOS
    • Labels:
    • Environment:

      Titanium Studio, build: 3.2.0.201311160316
      SDK build: 3.2.0.v20131117001643
      CLI: 3.2.0-alpha
      Alloy: 1.3.0 alpha
      Xcode 5.1 DP, iOS 7.1 beta

    • Story Points:
      3

      Description

      Details: Studio does not recognize Xcode 5.1 DP.

      Steps to reproduce:
      0. Download Xcode 5.1 DP
      1. Right-click in Project Explorer and go to New > Mobile App Project

      2. Pick either Alloy or Classic project and click next
      Actual: iPad and iPhone check boxes are not selected (see no_check_box.png)

      3. Fill in the required fields and select both iPad and iPhone check boxes
      4. Click next
      Actual: Studio will have a window that says iOS is not configured yet (see ios_config.png)

      Expected: Studio should be able to recognize Xcode 5.1 DP

      Note:
      1. If you pass the Platform Configuration screen, then you will be able to create the Titanium project.

      2. I see this warning error in ti info -t ios

      iOS Issues
      ! Xcode 5.1 is too new and may or may not work with Titanium SDK 3.2.0. The maximum supported
      Xcode version by Titanium SDK 3.2.0 is Xcode 5.0..

        Attachments

          Activity

            People

            • Assignee:
              mxia Michael Xia
              Reporter:
              wluu Wilson Luu (Inactive)
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: