Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5700

Configuration: Android - Studio 3.1.3.GA cannot detect Android SDK with Ti SDK 3.2.0 and Ti CLI 3.2.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.1.3
    • Component/s: Android
    • Environment:

      Titanium Studio, build: 3.1.3.201309132423
      SDK build: 3.2.0.v20131112123038
      Ti CLI: 3.2.0 master (4c816f21d7d9360659d77e9a6a994992ef880b72)
      OS: Mavericks (10.9)

      Description

      Details: Studio 3.1.3.GA cannot detect Android SDK with Ti SDK 3.2.0 and Ti CLI 3.2.0.

      But, the Ti CLI 3.2.0 was able to detect the Android SDK directory (see cli.log).

      Steps to reproduce:
      1. Open TiStudio 3.1.3.GA with 3.2.0 SDK and 3.2.0 CLI
      2. Wait for Studio dashboard to appear

      Actual: TiStudio will not be able to recognize the Android SDK (see dashboard.png and preferences.png).

      But, the Ti CLI 3.2.0 was able to recognize the Android SDK directory (see cli.log).

      Expected: TiStudio 3.1.3.GA should be able to recognize the Android SDK directory.

        Attachments

        1. cli.log
          17 kB
        2. dashboard.png
          dashboard.png
          447 kB
        3. preferences.png
          preferences.png
          70 kB

          Activity

            People

            • Assignee:
              mxia Michael Xia
              Reporter:
              wluu Wilson Luu (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: