Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5690

Configuration: iOS - "iPad" appears in the iOS simulator configuration when profiling or testing on iPhone simulator

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.2.0
    • Fix Version/s: 2013 Sprint 23, Release 3.2.0
    • Component/s: Configuration
    • Environment:

      Titanium Studio, build: 3.2.0.201311070117
      SDK build: 3.2.0.v20131107104043
      Ti CLI: 3.2.0 master (4c816f21d7d9360659d77e9a6a994992ef880b72)
      OS: Mac OS X Maverick (10.9)
      Xcode: 5.0.1

    • Story Points:
      5

      Description

      Details: "iPad" appears in the iOS simulator configuration when profiling or testing on iPhone simulator.

      This seems like a regression as this bug does not occur on the live stack.

      Steps to reproduce:
      1. Create default Titanium app
      2. Select the app
      3. Profile As OR Test As iOS Simulator > iPhone
      4. Once the simulator is launched, go to Profile As > Profile Configurations ... or Test As > Test Configurations ...

      Actual: "iPad" appears in the configuration (see attachment).
      Expected: "iPad" should not appear in the simulator configuration if profiling or testing on iPhone simulator.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                wluu Wilson Luu (Inactive)
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: