Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5491

Studio: Browse button does not work after installing a module

    Details

      Description

      Description

      In Titanium Studio, opening a window to install a new module works as expected. Selecting browse works on the first attempt and a module can be selected using the file picker. Installing the module works successfully. Subsequent attempts to use the browse button after this do not work and provide no error or other information about the lack of function.

      Steps To Reproduce

      1. Open Titanium
      2. Select marketplace module and download to your hard disk
      3. Help -> Install a mobile module
      4. Browse for the downloaded module, make sure it is still in zip format
      5. Don't change anything else and click install.
      6. After it has installed successfully open anything with a browse button. (Example, reopen module installer)
      7. Press "Browse..."

      Result

      Browse button does not open Finder.

      Expected Result

      Browse button should open the Finder again.

      WORKAROUND
      Closing and reopening studio will temporarily fix the bug, however the second time opening browse again will start the bug and no longer open Finder.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                sdowse Samuel Dowse
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: