Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-542

Studio-generated tiapp.xml is not always UTF-8

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Titanium Studio 1.0.4
    • Component/s: None
    • Labels:
      None
    • Environment:

      Titanium Studio 1.0.2.201107130739
      on Mac OS X 10.6
      w/ Titanium Mobile 1.7.2

      Description

      1. Start Titanium Studio
      2. Select "File" -> "New" -> "Titanium Mobile Project"
      3. Enter a project name (e.g. "sliff" – without the quotation marks)
      4. Enter a project id (e.g. "sliff" – without the quotation marks)
      5. Click "Finish"
      6. Observe the open editor for the tiapp.xml file
      7. Try to enter something like "FooCompany UG (haftungsbeschränkt)" (Hint: hitting Alt-U then a can generate the symbol for you)
      8. Save tiapp.xml
      9. Switch to the raw XML perspective by clicking on "tiapp.xml"

      Expected Result:
      10. See a row like this "<copyright>2011 by FooCompany UG (haftungsbeschränkt)</copyright>" or "<copyright>2011 by FooCompany UG (haftungsbeschr&#xE4;nkt)</copyright>"

      Actual Result:
      10. See a row like this "<copyright>2011 by FooCompany UG (haftungsbeschräöünkt)</copyright>"; this is not valid UTF-8 even though the first line of the XML document claims to be UTF-8

        Attachments

          Activity

            People

            • Assignee:
              nhuynh Natalie Huynh
              Reporter:
              cluepunk Sven Herzberg
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: