Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-5252

Xcode Base SDK: Even after setting the Tiapp to version 6.0 iOS, project is still installable on 5.1 iOS device.

    Details

    • Type: Story
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: Release 3.1.2
    • Fix Version/s: None
    • Component/s: iOS
    • Labels:
    • Environment:

      SDK: 3.1.2.v20130809141556
      Appcelertaor Studio: 3.1.2.201308091728
      OS: OSX 10.8.4
      Device: iPhone4(v 5.1)
      Xcode: 4.6.3

      Description

      Even after setting the Tiapp to version 6.0 iOS, project is still installable on 5.1 iOS device.
      This is not regression since the issue does not occur on 3.1.1GA as well.

      Steps to reproduce:
      1) Create a project in Studio with an iOS target
      2) Edit the tiapp.xml to include the following and save the changes:
      <ios>
      <min-ios-ver>6.0</min-ios-ver>
      </ios>
      3) Build the project
      4) Install and launch on iOS 5.x device
      5) Install and launch on iOS 6.x device

      Expected results:
      App installs and launches on only 6.x devices.
      On iOS 5.x, iTunes should issue a warning about needing to update to a later version of the iOS.

      Actual:
      App is installed on 5.x devices without any warning

        Attachments

          Activity

            People

            • Assignee:
              kkolipaka Kondal Kolipaka (Inactive)
              Reporter:
              amittal Anshu Mittal
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: