Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-4814

Users upgrading to Studio 3.1.1 can't run new Android projects due to the 2.3.3 sdk requirement

    Details

    • Story Points:
      5

      Description

      Steps:
      1. Run 3.0.0 Studio. Install the default Titanium SDK (3.1.0.GA)
      2. Upgrade to 3.1.1 Studio. Install the default Titanium SDK (3.1.1)
      3. Create a new Android project
      4. Run in the Android emulator
      5. An error message appears stating the minimum android sdk is 2.3
      6. Go to the preferences and change the default Android sdk to 2.3.3 (as suggested by the error message)
      7. Re-launch the Android emulator

      Expected:
      The launch works

      Actual:
      The same error message in step 5 is displayed

      Studio needs to indicate a better error message, or even set the default to 2.3.3 before the launch configuration is created. The way to fix this problem is to change the launch configuration created, which the user won't know to do since the error message doesn't indicate it.

      There needs to be a better flow here

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                nle Nam Le (Inactive)
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: