Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-4762

Node.ACS: Windows: installation failure with bson error

    Details

    • Story Points:
      8

      Description

      Problem
      I'm using Windows 7 32bit and run Titanium as Administrator, when I check for titanium updates, and install Node.ACS ver1.0.2, an error message appears like this:

      Error encountered during update
      Failed to install acs. Please see the Studio log for more information.

      Log

      !ENTRY com.aptana.js.core 4 0 2013-05-20 09:16:40.195
      !MESSAGE (Build 3.1.0.201304151600) [ERROR]  Failed to install acs.
       
      npm http GET https://registry.npmjs.org/acs
      npm http 304 https://registry.npmjs.org/acs
      npm http GET https://registry.npmjs.org/colors/0.6.0-1
      npm http GET https://registry.npmjs.org/commander/0.6.1
      npm http GET https://registry.npmjs.org/connect/2.3.5
      npm http GET https://registry.npmjs.org/connect-mongo/0.1.9
      npm http GET https://registry.npmjs.org/express/3.0.0
      npm http GET https://registry.npmjs.org/ejs/0.8.0
      npm http GET https://registry.npmjs.org/fstream/0.1.18
      npm http GET https://registry.npmjs.org/longjohn/0.0.3
      npm http GET https://registry.npmjs.org/mkdirp/0.3.3
      npm http GET https://registry.npmjs.org/node-uuid/1.3.3
      npm http GET https://registry.npmjs.org/pkginfo/0.2.2
      npm http GET https://registry.npmjs.org/socket.io/0.9.10
      npm http GET https://registry.npmjs.org/tar/0.1.13
      npm http GET https://registry.npmjs.org/uglify-js/1.3.2
      npm http GET https://registry.npmjs.org/temp/0.4.0
      npm http GET https://registry.npmjs.org/underscore/1.3.3
      npm http GET https://registry.npmjs.org/log4js/0.5.1
      npm http GET https://registry.npmjs.org/esprima/0.9.9
      npm http GET https://registry.npmjs.org/jade/0.28.1
      npm http GET https://registry.npmjs.org/string/1.1.0
      npm http GET https://registry.npmjs.org/request/2.14.0
      npm http GET https://registry.npmjs.org/wrench/1.3.9
      npm http GET https://github.com/appcelerator/cocoafish-node-sdk/tarball/0.1.6
      npm http GET https://registry.npmjs.org/npm/1.2.1
      npm http 304 https://registry.npmjs.org/connect-mongo/0.1.9
      npm WARN package.json connect-mongo@0.1.9 No README.md file found!
      npm http 304 https://registry.npmjs.org/express/3.0.0
      npm http 304 https://registry.npmjs.org/colors/0.6.0-1
      npm http 304 https://registry.npmjs.org/connect/2.3.5
      npm WARN package.json connect@2.3.5 No README.md file found!
      npm http 304 https://registry.npmjs.org/commander/0.6.1
      npm http 304 https://registry.npmjs.org/ejs/0.8.0
      npm http 304 https://registry.npmjs.org/fstream/0.1.18
      npm http 304 https://registry.npmjs.org/longjohn/0.0.3
      npm http 304 https://registry.npmjs.org/node-uuid/1.3.3
      npm http 304 https://registry.npmjs.org/mkdirp/0.3.3
      npm http 304 https://registry.npmjs.org/pkginfo/0.2.2
      npm http 304 https://registry.npmjs.org/socket.io/0.9.10
      npm http 304 https://registry.npmjs.org/tar/0.1.13
      npm http 304 https://registry.npmjs.org/uglify-js/1.3.2
      npm http 304 https://registry.npmjs.org/temp/0.4.0
      npm http 304 https://registry.npmjs.org/underscore/1.3.3
      npm http 304 https://registry.npmjs.org/log4js/0.5.1
      npm http 304 https://registry.npmjs.org/esprima/0.9.9
      npm http 304 https://registry.npmjs.org/jade/0.28.1
      npm http 304 https://registry.npmjs.org/string/1.1.0
      npm http 304 https://registry.npmjs.org/request/2.14.0
      npm http 304 https://registry.npmjs.org/wrench/1.3.9
      npm http 304 https://registry.npmjs.org/npm/1.2.1
      npm http 200 https://github.com/appcelerator/cocoafish-node-sdk/tarball/0.1.6
      npm http GET https://registry.npmjs.org/mongodb
      npm http GET https://registry.npmjs.org/graceful-fs
      npm http GET https://registry.npmjs.org/inherits
      npm http GET https://registry.npmjs.org/rimraf
      npm http GET https://registry.npmjs.org/inherits
      npm http GET https://registry.npmjs.org/block-stream
      npm http GET https://registry.npmjs.org/connect/2.6.0
      npm http GET https://registry.npmjs.org/range-parser/0.0.4
      npm http GET https://registry.npmjs.org/cookie/0.0.4
      npm http GET https://registry.npmjs.org/fresh/0.1.0
      npm http GET https://registry.npmjs.org/crc/0.2.0
      npm http GET https://registry.npmjs.org/methods/0.0.1
      npm http GET https://registry.npmjs.org/send/0.1.0
      npm http GET https://registry.npmjs.org/debug
      npm http GET https://registry.npmjs.org/socket.io-client/0.9.10
      npm http GET https://registry.npmjs.org/policyfile/0.0.4
      npm http GET https://registry.npmjs.org/redis/0.7.2
      npm http GET https://registry.npmjs.org/async/0.1.15
      npm http GET https://registry.npmjs.org/coffee-script
      npm http GET https://registry.npmjs.org/qs/0.4.2
      npm http GET https://registry.npmjs.org/mime/1.2.4
      npm http GET https://registry.npmjs.org/formidable/1.0.11
      npm http GET https://registry.npmjs.org/fresh/0.0.1
      npm http GET https://registry.npmjs.org/bytes/0.0.1
      npm http 304 https://registry.npmjs.org/inherits
      npm http 304 https://registry.npmjs.org/graceful-fs
      npm http 304 https://registry.npmjs.org/rimraf
      npm http 304 https://registry.npmjs.org/mongodb
      npm WARN package.json mongodb@0.9.9-8 No README.md file found!
      npm http 304 https://registry.npmjs.org/block-stream
      npm http 304 https://registry.npmjs.org/connect/2.6.0
      npm http 304 https://registry.npmjs.org/inherits
      npm http 304 https://registry.npmjs.org/range-parser/0.0.4
      npm http 304 https://registry.npmjs.org/cookie/0.0.4
      npm http 304 https://registry.npmjs.org/fresh/0.1.0
      npm http 304 https://registry.npmjs.org/crc/0.2.0
      npm http 304 https://registry.npmjs.org/methods/0.0.1
      npm WARN package.json methods@0.0.1 No README.md file found!
      npm http 304 https://registry.npmjs.org/send/0.1.0
      npm http 304 https://registry.npmjs.org/debug
      npm http 304 https://registry.npmjs.org/socket.io-client/0.9.10
      npm http 304 https://registry.npmjs.org/policyfile/0.0.4
      npm http 304 https://registry.npmjs.org/redis/0.7.2
      npm http 304 https://registry.npmjs.org/async/0.1.15
      npm http 304 https://registry.npmjs.org/coffee-script
      npm http 304 https://registry.npmjs.org/qs/0.4.2
      npm http 304 https://registry.npmjs.org/formidable/1.0.11
      npm http 304 https://registry.npmjs.org/mime/1.2.4
      npm http GET https://registry.npmjs.org/mime/1.2.6
      npm http 304 https://registry.npmjs.org/fresh/0.0.1
      npm http 304 https://registry.npmjs.org/bytes/0.0.1
      npm http GET https://registry.npmjs.org/hiredis
      npm http 304 https://registry.npmjs.org/mime/1.2.6
      npm http GET https://registry.npmjs.org/qs/0.5.1
      npm http GET https://registry.npmjs.org/bytes/0.1.0
      npm http GET https://registry.npmjs.org/send/0.0.4
      npm http GET https://registry.npmjs.org/pause/0.0.1
      npm http GET https://registry.npmjs.org/bson/0.0.4
      npm http 304 https://registry.npmjs.org/hiredis
      npm http 304 https://registry.npmjs.org/bson/0.0.4
      npm WARN package.json bson@0.0.4 No README.md file found!
      npm http GET https://registry.npmjs.org/bindings
      npm http GET https://registry.npmjs.org/uglify-js/1.2.5
      npm http GET https://registry.npmjs.org/ws
      npm http GET https://registry.npmjs.org/xmlhttprequest/1.4.2
      npm http GET https://registry.npmjs.org/active-x-obfuscator/0.0.1
       
      > bson@0.0.4 install C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\connect-mongo\node_modules\mongodb\node_modules\bson
      > node install.js
       
      'node' is not recognized as an internal or external command,
      operable program or batch file.
      npm http 304 https://registry.npmjs.org/bytes/0.1.0
      npm http 304 https://registry.npmjs.org/qs/0.5.1
      npm http 304 https://registry.npmjs.org/send/0.0.4
      npm http 304 https://registry.npmjs.org/uglify-js/1.2.5
      npm ERR! Error: ENOENT, lstat 'C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\npm\node_modules\ini\ini.js'
      npm ERR! If you need help, you may report this log at:
      npm ERR!     <http://github.com/isaacs/npm/issues>
      npm ERR! or email it to:
      npm ERR!     <npm-@googlegroups.com>
       
      npm ERR! System Windows_NT 6.1.7600
      npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "-g" "install" "acs" "--color" "false"
      npm ERR! cwd C:\Users\MRiz\AppData\Local\Titanium Studio
      npm ERR! node -v v0.8.22
      npm ERR! npm -v 1.2.14
      npm ERR! path C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\npm\node_modules\ini\ini.js
      npm ERR! fstream_path C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\npm\node_modules\ini\ini.js
      npm ERR! fstream_type File
      npm ERR! fstream_class FileWriter
      npm ERR! code ENOENT
      npm ERR! errno 34
      npm ERR! fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
      npm ERR! fstream_stack Object.oncomplete (fs.js:297:15)
      npm http 304 https://registry.npmjs.org/ws
      npm http 304 https://registry.npmjs.org/xmlhttprequest/1.4.2
      npm http 304 https://registry.npmjs.org/pause/0.0.1
      npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\express\node_modules\connect'
      npm ERR! error rolling back  acs@1.0.2 { [Error: ENOTEMPTY, rmdir 'C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\express\node_modules\connect']
      npm ERR! error rolling back   errno: 53,
      npm ERR! error rolling back   code: 'ENOTEMPTY',
      npm ERR! error rolling back   path: 'C:\\Users\\MRiz\\AppData\\Roaming\\npm\\node_modules\\acs\\node_modules\\express\\node_modules\\connect' }
      npm ERR! bson@0.0.4 install: `node install.js`
      npm ERR! `cmd "/c" "node install.js"` failed with 1
      npm ERR!
      npm ERR! Failed at the bson@0.0.4 install script.
      npm ERR! This is most likely a problem with the bson package,
      npm ERR! not with npm itself.
      npm ERR! Tell the author that this fails on your system:
      npm ERR!     node install.js
      npm ERR! You can get their info via:
      npm ERR!     npm owner ls bson
      npm ERR! There is likely additional logging output above.
       
      npm ERR! System Windows_NT 6.1.7600
      npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "-g" "install" "acs" "--color" "false"
      npm ERR! cwd C:\Users\MRiz\AppData\Local\Titanium Studio
      npm ERR! node -v v0.8.22
      npm ERR! npm -v 1.2.14
      npm ERR! code ELIFECYCLE
      npm http 304 https://registry.npmjs.org/active-x-obfuscator/0.0.1
      npm http GET https://registry.npmjs.org/zeparser/0.0.5
      npm http 304 https://registry.npmjs.org/bindings
       
      > hiredis@0.1.15 install C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\socket.io\node_modules\redis\node_modules\hiredis
      > node-gyp rebuild
       
      'node-gyp' is not recognized as an internal or external command,
      operable program or batch file.
      npm WARN optional dep failed, continuing hiredis@0.1.15
      npm http GET https://registry.npmjs.org/tinycolor
      npm http GET https://registry.npmjs.org/options
      npm http 304 https://registry.npmjs.org/zeparser/0.0.5
      npm http 304 https://registry.npmjs.org/tinycolor
      npm http 304 https://registry.npmjs.org/options
       
      > ws@0.4.25 install C:\Users\MRiz\AppData\Roaming\npm\node_modules\acs\node_modules\socket.io\node_modules\socket.io-client\node_modules\ws
      > (node-gyp rebuild 2> builderror.log) || (exit 0)
       
      npm
       
      !ENTRY com.appcelerator.titanium.update 4 4 2013-05-20 09:16:40.227
      !MESSAGE Error encountered during update
      !SUBENTRY 1 com.aptana.js.core 4 0 2013-05-20 09:16:40.227
      !MESSAGE Failed to install acs. Please see the Studio log for more information.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                dhyde Dustin Hyde
              • Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: