Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-4202

Debugger: Android Debug Progress window bad behavior on Windows

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Titanium Studio 3.1.0
    • Component/s: Debugging
    • Environment:

      Appcelerator Studio 3.1.0.201304082106
      TiSDK: 3.1.0.v20130409124549
      Windows OS (Ultimate x64 version)
      CLI 3.1.0-cr
      tested on Android Nexus One (2.3.6)

    • Story Points:
      5

      Description

      Problem description

      On Windows, the 'Debug on Android device' progress window it's not showing the progress as expected, eventually not automatically hiding.

      Steps to reproduce

      Only reproducible on Windows.

      1. Create a new project (classic or alloy)
      2. Set a breakpoint and launch the debugger on Android device

      Result: the 'Debug on Android device' window appears. No progress is shown after the second bullet 'Device connected. Performing pre compilation tasks'.
      The progress actually goes on and eventually the app is launched and breakpoints works fine, but the window stays on top.

      3. Click on the 'Hide' button.
      Result: the window is placed on the background and the user is able to use the debugger as expected. However, a 'Debug on Android Device' bottom right notification is displayed - clicking on it, the Debug Progress is shown again as stuck at the second bullet.
      See screenshots.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                fcasali Federico Casali
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: