Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-3216

Node.js with version 8.17 gets installed but popup prompts to install version 8.14 and displays 8.14 is installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Invalid
    • Affects Version/s: Titanium Studio 3.0.2
    • Fix Version/s: None
    • Component/s: Node
    • Environment:

      OS: Mountain Lion OSX 10.8.2
      Titanium Studio: 3.0.2.201301101840
      Titanium SDK: 3.0.1.v20130115150204

      Description

      Its a regression issue since earlier, studio was installing 8.14(old version) of studio.
      Steps To Reproduce:
      1. Uninstall all plugins
      2. Start studio [Pop-up to install nodejs, CLI, Alloy appears]
      Actual: Nodejs version 8.14 appears
      3. Install the nodeJS
      Actual: Titanium update prompt on down-right shows 8.14 nodejs is installed successfully
      4. Verify version using command "node -v"
      Actual: v0.8.17 version appears.
      [refer attachments]

      Expected: The right Version must appear on all pop-ups.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                prastogi Pragya Rastogi
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: